Problema
Depois de gerar tráfego para seu aplicativo e esperar cinco minutos, nenhum dado do agente .NET aparece na interface do New Relic.
Solução
A ausência de dados pode ocorrer por diversos motivos.
Common causes
para dados faltantes: Veja as soluções básicas de resolução de problemas.
Other situations:
Se as soluções básicas não resolverem o problema, a falta de dados pode ser mais intrínseca ao seu sistema. Para mais informações, consulte as soluções avançadas de resolução de problemas.
Microsoft Azure users:
Consulte as soluções de resolução de problemas do Azure.
No browser data appears:
Veja as dicas de resolução de problemas ao usar o agente browser.
Soluções básicas
Para solucionar os motivos mais comuns de falta de dados, tente estas soluções conforme aplicável.
Basic solutions | Comments |
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Verifique a compatibilidade do aplicativo e framework com o agente | Compatibilidade e requisitos framework .NET ou |
Saiba mais sobre problemas comuns de instalação | Consulte resolução de problemas para .NET Core e Linux ou resolução de problemas para Windows |
Configurar para processo .NET de curta duração | Se você tiver um processo de curta duração (menos de 60 segundos), ele poderá não relatar dados. Para obter mais informações, consulte Monitorar processos de curta duração. |
.NET Core: Verifique os requisitos do Kestrel. | Certifique-se de estar usando um aplicativo/servidor web Kestrel compatível com New Relic. Caso contrário, talvez seja necessário garantir que seu agente .NET tenha o suporte ao .NET Framework habilitado. |
.NET Core: Verifique as variáveis de ambiente. | Certifique-se de ter configurado todas as variáveis de ambiente necessárias e reinicie o agente. |
.NET Framework: Reinicie o IIS. | Se o seu aplicativo não estiver recebendo tráfego, nenhum dado será informado à New Relic. Para reiniciar o IIS:
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Execute o diagnóstico New Relic . | Para tentar identificar automaticamente o problema, use o New Relic Diagnostics. |
Verifique se há conflitos no criador de perfil. | Se você estiver usando o System Center Operations Manager (SCOM) da Microsoft, siga os procedimentos de resolução de problemas para resolver conflitos de .NET e SCOM. |
Revise o arquivo de log. | Se existir arquivo de log , abra-os e verifique se há erros. |
Soluções avançadas
Para solucionar problemas mais complexos quando nenhum dado aparece, tente estas soluções conforme aplicável:
Advanced solutions | Comments |
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.NET Framework: Verifique as permissões do Registro. | Verifique se há um erro de permissão de chave de registro. |
.NET Framework: Execute o Visualizador de eventos do Windows. | Se aplicável:
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Obtenha o log de depuração. | Se o seu registro não mostrou erros, aumente o nível de registro temporariamente para coletar |
Verifique as configurações de proxy. | Certifique-se de que suas configurações de proxy estejam corretas e que incluam um atributo de host. |
.NET 8: Certifique-se de que os diagnósticos de tempo de execução estejam ativados | A partir do .NET 8, definir a variável de ambiente |
Obtenha ajuda adicional. | Se os dados ainda não aparecerem, obtenha suporte em support.newrelic.com. |